AgTalk Home
AgTalk Home
Search Forums | Classifieds (65) | Skins | Language
You are logged in as a guest. ( logon | register )

Jeep Liberty diesel turbo died,,, lesson learned
View previous thread :: View next thread
   Forums List -> Machinery TalkMessage format
 
Jay NE Ohio
Posted 10/30/2012 09:27 (#2668564)
Subject: Jeep Liberty diesel turbo died,,, lesson learned



northeastern Ohio

The turbo on my Jeep Liberty CRD (common rail diesel) went out on Sunday when I was 100 miles from home.  It started making a whistling sound back in June (4 months ago), but I decided to keep running it.  There were no other signs of imminent failure (did not use any oil, fuel economy was unchanged, no loss of power).  I pulled the hose off in June to check for play and did not detect any significant play in the shaft.  The Jeep only has 80k on the odometer (bought it used, might not be right).  It was the first Liberty diesel I bought,,, I now have 3 and really like them.  Back to the story: 

 

I was on the highway when it failed and drove it to the next exit (about 1/2 a mile).  There was a huge cloud of smoke whenever I gave it any throttle, but I limped it to a parking lot.  My dad brought a trailer and I drove it on.  Pulled it into my shop when I got home and drained the oil.  There was only a quart left in the pan!!!!  I pulled the turbo (about 2 hour job).  I then installed a used turbo in the CRD.   I put new oil in the pan and a new filter.   Did a quick lookover, and everything seemed to be in order.

 

Here is where the fun begins!  I started the engine and let it idle while the oil pressure came up.  It seemed to be running fine.  I let it idle for a couple minutes while the oil warmed up.  I then gave it a little throttle (2000 rpm) and it sounded great.  So I gave it more throttle (about 3000 rpm).  I sounded great for a second and then suddenly went to 4000 rpm.  I instantly removed my foot from the throttle.  And then it went to 5000 rpm ( I am guessing on the rpm).....  I quickly turned the key off.  The engine continued to race as my shop filled with black smoke.  It ran like mad for at least 30 seconds and then finally came to a stop.

 

I went to the house and ate lunch while the smoke cleared.  Later I went to see what was left of my Jeep.  Surprisingly, there were no puddles of oil or holes in the side of the block.  There was a black stain on the concrete where the tailpipe turns down.  The oil level in the pan was still on the full mark.

 

I figure that the intercooler was full of oil and when I gave it some throttle, it started sucking that oil right into the intake.  Turning the key off probably saved the engine from going past the point of no return (limited the "fuel" to just the oil in the intercooler).  

 

I pushed the Jeep out of the shop and fired up the engine again.  It ran fine until I gave it some throttle.  The rpm's danced around the red line again, but soon it smoothed out.  I let it run for a few minutes while I varied the throttle.  A little smokey, but no too bad.  I decided to take it around the block to see if I could use up the rest of the oil in the intercooler.  By the time I got back, it had quit smoking and seems to be running normal.

 

So the lesson here:  if you have turbo failure, don't forget to clean the oil out of the intercooler. 

Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)