AgTalk Home
AgTalk Home
Search Forums | Classifieds (49) | Skins | Language
You are logged in as a guest. ( logon | register )

Raven smartsteer issues.
View previous thread :: View next thread
   Forums List -> Precision TalkMessage format
 
sparrell
Posted 5/11/2022 20:20 (#9656784 - in reply to #9656633)
Subject: RE: Raven smartsteer issues.



gene_champ - 5/11/2022 18:26

I have the smart steer on a cruiser. It always worked great including last year.
Now I still get the flashing lights on the node. Good power and ground.

I get the disclaimer on the cruiser screen on startup. I do not however get the steering wheel symbol on the screen, nor does autosteer engage.

Is there any troubleshooting guide for these? I am guessing raven no longer supports them. Probably ag express didn't either although I hadn't checked with them yet. I bought it from sprayer specialities, but I have never got great service from them or raven.

I know it is old but been a good system for my needs. I have an identical system in another tractor and it still works great.

I talked to a dealer about an in command and steady steer last year but now I hear they are hard to get.


Just a guess, but it sounds like its either a smartsteer node issue or something with the harness. If you can confirm that there is no physical damage to the harness, maybe try to reload the latest software on the smartsteer node?

The steering icon in the upper left corner of the screen is not there at all?



Edit to add: if you have two complete systems, maybe switch the node and harness from the working system one at a time to narrow it down?

Edited by sparrell 5/11/2022 20:24
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete cookies)