AgTalk Home
AgTalk Home
Search Forums | Classifieds (78) | Skins | Language
You are logged in as a guest. ( logon | register )

2014 Ford Expedition - Would you say I'm overcharged on R134?
View previous thread :: View next thread
   Forums List -> Machinery TalkMessage format
 
hillfarmer
Posted 7/10/2024 07:35 (#10805099 - in reply to #10804850)
Subject: RE: 2014 Ford Expedition - Would you say I'm overcharged on R134?



730diesel - 7/9/2024 23:36

Take a look at my gauge readings and let me know what you think.

I know last summer I popped one can in this thing. Probably a mistake. To me my low side is a bit high and high side as well. It was about 84 degrees out.

This car has high miles, 305,000. I think my evaporator in the front it plugged with garbage as the front vent air flow is poor. The rear auxilary vents blow great so I assume that evaporator is crystal clean. The outlet temp in the front or rear only gets down to 56 degrees.

I charged both a 89 and 97 Chevy pickup today and one sat at 26 psi low side, the other at 30 psi low side. The 97 had a vent temp of 40. Both pickups had ice on low side lines and were very nice and cold inside.

I'm thinking I'm overcharged on the Expedition. Thoughts?

Edit, the pic with both gauges the low side is 36. I can't get it to show right for some reason.


I would spray a can of foaming cleaner on the condenser
then bore scope the vents ,try and blow out the evaporator to get air moving
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete cookies)