AgTalk Home
AgTalk Home
Search Forums | Classifieds (129) | Skins | Language
You are logged in as a guest. ( logon | register )

Iveco ticking noise solved!!!
View previous thread :: View next thread
   Forums List -> AgTalk CafeMessage format
 
Jim Naden
Posted 5/12/2022 17:05 (#9657910 - in reply to #9657537)
Subject: RE: Iveco ticking noise solved!!!



Southeastern Tipton County, Indiana

Rosco - 5/12/2022 10:53 So last fall my brothers 435 started making a ticking noise in the top end. We noticed that the turbo was starting to bypass a bit of oil as it had rotted out the boot below the turbo. So we changed the turbo hoping that was the cause of the ticking. Nope. Mechanic thought maybe it was valves. So he took the cover off the top and started adjusting valves and noticed a little pin laying on top of the head. It’s about an inch long and 3/8 in diameter with a bit of knurling in the middle to hold it in place in an arm. When this engine is used in highway trucks this arm is part of the Jake system, but in field tractors it is pinned up. So in our case, the little pin fell out and the arm was just bouncing around making the ticking noise. The hole in the arm was worn a bit and the pin wouldn’t stay in so we tacked it in with a mig! I know that’s not NAT approved but it would have been weeks getting parts. Now she runs like a top. The mechanic found the same little pin in the oil pan of a 375, and had no idea where it came from. Now he knows. Rosco


We've had trouble with the clips breaking, makes more than just "a little tick".

Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete cookies)