AgTalk Home
AgTalk Home
Search Forums | Classifieds (43) | Skins | Language
You are logged in as a guest. ( logon | register )

504 Super I Problems
View previous thread :: View next thread
   Forums List -> Machinery TalkMessage format
 
dvcochran
Posted 6/2/2019 18:21 (#7537763)
Subject: 504 Super I Problems


I have a 504 Super I. I bales with it last year and it did Ok but not great. I knew the pickup drive clutch was out when I bought it. I have done the following work to the baler:
Replaced pickup drive clutch
Replaced all pickup cam follower bearing
Replaced all pickup teeth
Unstuck hydraulic density adjustment pilot valve and recharged system.
Repaired broken wire in monitor cable
Chains and sprockets look good

The baler auto-ties as it should
I baled last week and had several bales that tied only one string. I think this was mostly a mucked up ball of twine but not certain.
There was a lot of hay getting in front of the belts but the windrows were light and dry. I was running the baler at a few hundred rpm under 540. Can I do anything to reduce this?
When I parked the baler and blew is off I discovered there was a lot of hay inside the belts. Can I reduce this?
I put the bales in the barn today and found that they were very loose and many of them had hay on the outside of the strings and looked shabby. I had the bale density set where it maxed out at 800psi. A friend who custom bales with a 6640 said he thinks I should remove the belts and cut them to the same length and re-lace. Does this make sense?
I do not know where to start to troubleshoot the baler.
Thanks for any suggestions.
I have went through the same problems with a 5410 rebel. One set of new belts that were supposed to work were too thick and would curl against the belt dividers and not turn. Net would not feed with another set of new belts through the Vermeer dealer all belts tracked great except one. The belt company would not take my word for it and said to bring to dealer or verification. Finally after the tech changing the location of the belt and sending video to the belt company they did send new belt I had to pay for the tech hours and still will not work. I have spent enough on this baler to have bought a new one. And now I still have a baler that I am working on. Sell your baler and problems to someone else and buy a new one. String tie only a new 5420 would cost around $20000 with no interest for 60 months. I have spent close to $7500 on this baler and it still is not working. I have ordered new net cutting knife and will install and cross my fingers that this will help.
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)