AgTalk Home
AgTalk Home
Search Forums | Classifieds | Skins | Language
You are logged in as a guest. ( logon | register )

Vermeer 504 Super I Problems
View previous thread :: View next thread
   Forums List -> Machinery TalkMessage format
 
dvcochran
Posted 6/1/2019 08:01 (#7535133)
Subject: Vermeer 504 Super I Problems


I have a 504 Super I. I bales with it last year and it did Ok but not great. I knew the pickup drive clutch was out when I bought it. I have done the following work to the baler:
Replaced pickup drive clutch
Replaced all pickup cam follower bearing
Replaced all pickup teeth
Unstuck hydraulic density adjustment pilot valve and recharged system.
Repaired broken wire in monitor cable
Chains and sprockets look good

The baler auto-ties as it should
I baled last week and had several bales that tied only one string. I think this was mostly a mucked up ball of twine but not certain.
There was a lot of hay getting in front of the belts but the windrows were light and dry. I was running the baler at a few hundred rpm under 540. Can I do anything to reduce this?
When I parked the baler and blew is off I discovered there was a lot of hay inside the belts. Can I reduce this?
I put the bales in the barn today and found that they were very loose and many of them had hay on the outside of the strings and looked shabby. I had the bale density set where it maxed out at 800psi. A friend who custom bales with a 6640 said he thinks I should remove the belts and cut them to the same length and re-lace. Does this make sense?
I do not know where to start to troubleshoot the baler.
Thanks for any suggestions.
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete all cookies set by this site)