AgTalk Home
AgTalk Home
Search Forums | Classifieds (266) | Skins | Language
You are logged in as a guest. ( logon | register )

Phantom 3 batteries won't charge
View previous thread :: View next thread
   Forums List -> Drone TalkMessage format
 
scott312
Posted 6/23/2022 19:55 (#9718269 - in reply to #9717683)
Subject: RE: Phantom 3 batteries won't charge


Iowa
heronlk - 6/23/2022 10:59

Try holding in the button of the battery while plugged in. I believe if i remember correctly it will go thru a diagnostic sequence and hopefully will start charging. I don't have that drone by me right now, but i know i've tried this in the past.


Thanks, I tried that. When I hold the button in for a few seconds, it starts blinking red (the 4 green lights stay solid green). When I let the button go, it stays lit up for a couple seconds and then goes everything goes off again. I tried this several times with it plugged in and not plugged in. Unfortunately, no change in ability to charge.
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete cookies)