AgTalk Home
AgTalk Home
Search Forums | Classifieds (130) | Skins | Language
You are logged in as a guest. ( logon | register )

2630 display not working right
View previous thread :: View next thread
   Forums List -> Precision TalkMessage format
 
NDwheat
Posted 6/7/2021 23:48 (#9047466)
Subject: 2630 display not working right


cavalier county
I have a 2630 with JD rate controller and integrated autotrac in an Apache sprayer. Tonight for the first time I couldn't get it to record or paint on the headland, after messing around it I got it to paint but then my icon was either not moving, the map would appear froze or it made a strange pattern. I'm probably not doing a very good job of describing the issue.
The rate controller and speed seemed to work right but sectional control doesn't with no coverage recorded. It's was getting dark so I didn't dare keep on, tomorrow I can get by shutting it off manually and following the airseeder cart tracks but that won't work in taller crop.
I also noticed that my screen has what appears to be the 'death bubble' across the top and about halfway down the sides. It's about 1/8" wide. When the screen bubbles is the display usually shot or just the touchscreen? Due to the section control not working, I think it's more serious than just a touchscreen. I'll call the dealer when they open and swap the screen with a tractor when it gets too windy but would appreciate any input on the problem.
TIA, good night.
Top of the page Bottom of the page


Jump to forum :
Search this forum
Printer friendly version
E-mail a link to this thread

(Delete cookies)