PWM Hydraulic Drive-Tedbear?
tedbear
Posted 9/16/2022 06:13 (#9846369 - in reply to #9846153)
Subject: RE: PWM Hydraulic Drive-Tedbear?


Southern Minnesota
I'm not familiar with that valve. Are you certain it is a PWM control valve. It may be another type of valve.

The valves I'm familiar with (they were made by the BRAND company) have 3 ports. The ports are labelled IN (pressure in from tractor), CF (Controlled flow out to the orbit motor) and EX (EXcess flow which is sometimes used, sometimes not).

With a modern farm tractor, the oil from the tractor goes to the IN port of the valve, the oil from the CF port goes to the IN port of the orbit motor. The OUT port from the orbit motor goes back to the tractor. The EX port on the valve is plugged. The purpose of the valve is to restrict the flow from the tractor to the orbit motor. This is fine with a modern tractor as you don't need to be concerned about the EXcess flow.

With an older tractor or open center system, the oil from the tractor also goes to the IN port of the valve, the oil from the CF port goes to the IN port of the orbit motor. The EX port needs a hose and a tee to tie into the hose coming from the orbit motor OUT port on its way back to the tractor. This means the oil flow coming from the tractor is split with some going to the orbit motor as before and the rest is returning to the tractor along with any oil coming out of the orbit motor.

The difference between the two is amount to either blocking off the EXcess oil or directing it somewhere for another use or returning it to the tank.

Since your valve is a different style, I'm not certain as to how to plumb it. Again, it must be a PWM control valve. I have found that connecting up these valves "backwards" in some sense will often result in action but not what you want. It is very confusing since you don't really know where the oil is going.

Here's what I would do if I were in your situation: Connect the hoses to the tractor as you feel to be correct. Leave the Weatherpack connector on the PWM valve unplugged. This will keep any confusion with the Integra out of the picture. Activate the tractor hydraulics, the orbit motor should never receive any oil and should not turn. Try it with the hydraulic lever or switch the other way. No matter what you do, the orbit motor should NOT turn. If it does, there is a problem with your plumbing (assuming the valve is good).

OK, suppose the orbit motor does not turn, now use a jumper to apply 12V power and ground to the two poles of the electrical connector. Connecting either way should not matter. Now the plunger in the PWM valve should be fully open so try the hydraulics again. Now the orbit motor should turn at maximum speed determined by the speed of the tractor hydraulics.

Hopefully at this point this should be very reliable. No power - No oil flow to the orbit motor. 12V to the coil, maximum oil flow and speed at the orbit motor. Until this works in this manner, there is no point in connecting to the Integra yet as you need to get to the bottom of the plumbing confusion.

Once you are past that hurdle then connect to the Integra. The Integra must be setup as a PWM valve. I'd try a frequency of 100 Hz. Now in Manual, when you turn on the Master, the Integra should send 12V ON/OFF pulses to the valve coil which should open it somewhat. This should make the orbit motor turn. Using the INCrease and DECrease arrows should allow you to change the speed of the orbit motor. If Increase and Decrease change the speed of the motor but backwards, there is still something wrong.

If ON/OFF and Increase/Decrease work properly, then and only then should you try the automatic rate option since if the system cannot be controlled reliably in Manual the auto systems has no chance of working correctly.

Good luck



Edited by tedbear 9/16/2022 06:24
Top of the page Bottom of the page